OLEX2-1.3 - Error message/HTML panel not displayed

Olex2 related issues, ideas, troubleshooting and of course general Olex2 related tomfoolery its all good and welcome. Linux, Mac even Windows all goes in here

Link: Olex2 Homepage

Moderators: oleg, HorstPuschmann

Hein
Posts: 4
Joined: 02 Mar 2015, 17:13

OLEX2-1.3 - Error message/HTML panel not displayed

Post by Hein » 04 May 2020, 21:12

Hi,
I am posting this for a student of mine while he is trying to fix his OLEX2 installation. After a clean install and running OLEX2-1.3 for some time (Windows 10), the HTML panel on the right was not displayed anymore and he got some debugging error messages which seem to be related with loading the tool panel (see attached screen shot). Deactivating/Reactivating the HTML panel in the View Menu repeats these error messages.

He told me that this happened before but he got around it by de- and re-installing OLEX2. But this time the problem persists after a reinstall. He is currently trying to do an "as clean as possible" - reinstall, but I thought I post the issue here in case that somebody has seen that before and would know of a quick fix.

Cheers,
Hein

User avatar
oleg
Olex2 Boffin
Posts: 807
Joined: 24 Nov 2008, 21:34

Re: OLEX2-1.3 - Error message/HTML panel not displayed

Post by oleg » 05 May 2020, 15:22

Hi Hein,

unfortunately there is no screenshot attached. You can get the full log file using:

Code: Select all

SetVar defeditor notepad
log
Cheers,
Oleg.

Hein
Posts: 4
Joined: 02 Mar 2015, 17:13

Re: OLEX2-1.3 - Error message/HTML panel not displayed

Post by Hein » 05 May 2020, 17:38

Hi Oleg,

Thank you for the fast reply. The student followed my advice in the interim: de-installed, deleted all remaining OLEX2 registry entries and reinstalled. With the addition of cleaning the registry and doing some additional reboots, the re-install worked fine this time and OLEX2 is running clean. Should that problem reappear, we''ll send you the log file.

Cheers,
Hein

User avatar
oleg
Olex2 Boffin
Posts: 807
Joined: 24 Nov 2008, 21:34

Re: OLEX2-1.3 - Error message/HTML panel not displayed

Post by oleg » 05 May 2020, 19:03

You do not need all those manipulations - reinstalling Olex2 does not help unless you do not delete the user data/preferences directory (Uninstaller offers that option). Its location is displayed when you do:

Code: Select all

echo DataDir()
or

Code: Select all

shell DataDir()
This is the only directory where Olex2 stores data - deleting it makes Olex2 as good as new.

Cheers,
Oleg.

Hein
Posts: 4
Joined: 02 Mar 2015, 17:13

Re: OLEX2-1.3 - Error message/HTML panel not displayed

Post by Hein » 05 May 2020, 20:51

Thanks! I bookmark this for any other potential problems.

Do not forget that we are all Windows-trained now. Turning-it-off-and-on-again or the reinstallation equivalent for software is considered high-end trouble-shooting now-a-days. ;)

Cheers,
Hein

Return to “Olex2”